Wednesday, July 21, 2010

SugarCRM Unable to Open a Required File??

Does this error look familiar to you? 

Fatal error: SugarBean::require_once() [function.require]: Failed opening required '' (include_path='C:\xampp\xampp\htdocs\sugarce55\include/..;.;C:\xampp\xampp\php\pear\') in C:\xampp\xampp\htdocs\sugarce55\data\SugarBean.php on line 3367 

I ran into the above error a few days ago when accessing the ListView for Tasks. Seemed rather puzzling as it had worked without errors just 2 - 3 minutes prior to that. I should point out this occurred on my development system, so there weren't any other users logged into SugarCRM that could have in turn broken something. 

Anyway, I quickly realized that when it did work, the Tasks table was empty. Seemed like a strange error for it to be related to data, but that's where things were pointing.

Wednesday, July 14, 2010

Release Time - SugarCRM 6.0

Yesterday, the good folks at SugarCRM announced the General Availability of version 6.0 of its flagship product, SugarCRM.

Although some folks I interact with are eager to upgrade, I generally recommend folks wait 3 - 4 months AFTER the initial release of ANY software package before considering it production ready.  That statement has a tendency to draw some fire, as people like to point out that since SugarCRM itself has stated it is ready for use by the masses, it should be fine.  

Allow me to explain my reasons, in hopes of also helping you avoid some headaches.